Announcement

Collapse
No announcement yet.

What happened to my central locking?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • What happened to my central locking?

    My central locking decided to break down overnight. Here's what happened:

    Wife forgot the keys outside in the rain about a year ago. The Ir remote did not like it and it refused to work. Central locking worked fine using the lock in the door.

    A week ago I decided to replace the key batteries. To my surprise the ir locking became fuctioning again! I thought the rain broke the key but turn out the batteries died at the same time. So I had fully functioning remote central locking. For a few days.

    This morning I tried unlocking the car using the key remote: nothing. Then I tried the drivers door: it just opens the door I use the key at, not all doors

    I already tried reprogramming the key, removing and inserting the key batteries and removing the battery earth strap for few minutes. None of that worked. Any ideas what is causing my problem? Cannot access the boot at the moment since I don't have correct key for it and it only unlock via central locking

    Edit: Central locking locks all doors ok, but does not open any of them?

  • #2
    That's sometimes caused by a broken wire inside the door / wing boot
    Mike

    http://www.s2-audi.co.uk

    Comment


    • #3
      I did some measuring and testing for the pump today. Signal from the door locks reach the pump so that suggests it is not a broken wire. I also tried to unlock the doors by bridging the door lock connector pins but its still the same: it locks but won't unlock. I presume that its a problem with the pump itself so I ordered a new one.

      Comment


      • #4
        Have you tried from the passenger door with a key?

        Comment


        • #5
          I tried it and it's all the same. Let's see if the new pump sorts it.

          Comment


          • #6
            If it doesn’t then it might be at the ecu. There is something called “ a pin 27 reset “ or something like that. No doubt a more knowledgeable member than me will correct it. Anyway, you earth the pin and hey presto everything works again! And you’ve got a spare pump into the bargain.
            https://www.s2forum.com/forum/techni...-locking-issue
            Last edited by 4WDrifter; 4th July 2019, 15:03.
            1996 S2 ABY Coupe silver
            2003 S3 8L dolphin grey
            2014 RS4 B8 prism silver

            Comment


            • #7
              This thread might explain better
              https://www.s2forum.com/forum/techni...in27-ecu/page2
              1996 S2 ABY Coupe silver
              2003 S3 8L dolphin grey
              2014 RS4 B8 prism silver

              Comment


              • #8
                I don't think the ecu has much to do with the central locking. The car runs just fine Although it didn't when I took the vac pump out and tried to start the car. Turns out that with the vacuum pump disconnected the starter does not turn. It scared me off for a while until I figured it has to do something with the pump. Plugged it back in and the car fired up You learn something every day

                Comment


                • #9
                  This is now sorted, old central locking pump was faulty. I plugged in a working pump and programmed the remote keys and everything works again

                  Comment

                  Working...
                  X