Announcement

Collapse
No announcement yet.

B4 sunroof tilts but won't slide!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • B4 sunroof tilts but won't slide!

    Hi guys, been browsing this forum for a while ever since I bought my first audi - a 94 80 avant, and have found this to be a great place for help! I have done some searches but couldn't find the answers to my sunroof issues...

    The motor seems to work fine and opens in the tilt position but struggles and jams when trying to slide it back. Trying to manually open it with the key is very stiff and not happy forcing the mechanism... I have had it open but takes force to push it back on the sliders...

    These arms arent attached to anything on both sides and can't see where they are supposed to connect. Any ideas? Looks like it has been apart before and o was wondering if these are in the wrong place they could be getting in the way.

    Any help appreciated!!
    Attached Files

  • #2
    Those arms should attach to the drip tray. This is a channel which sits under the join between the roof and the panel across the car, it's probably detached and hiding back there somewhere. When this is detached your headlining normally gets wet.

    S2 Coupe 3B Project


    Ur quattro restoration

    S2 Avant

    Boost is the new rock and roll!
    sigpic

    Comment


    • #3
      B4 sunroof tilts but won't slide!

      There's a pic here
      Worth reading that whole thread and the other water leak stickies in that forum


      Another leaky Coupe, sunroof problems

      https://r.tapatalk.com/shareLink?url...0&share_type=t

      S2 Coupe 3B Project


      Ur quattro restoration

      S2 Avant

      Boost is the new rock and roll!
      sigpic

      Comment


      • #4
        Thanks for the reply! I will look into it further and try to fish that drip tray out if it is still in there. There is some water around above the headlining but all seems to be draining properly and no sign of coming through the materiall. Have a small trickle entering the drivers footwell but I think that is coming from elsewhere.

        Comment


        • #5
          I have this issue at the moment, the motor will tilt the panel but when slide is selected it drops the panel to be able to slide but then there are a few clicks and it doesn't move back. As if there is somethong jamming the mechanism or a sensor is at fault.

          Using the manual winder won't budge it backwards either so think there must be something jamming it, any pointers on where to look?

          Comment


          • #6
            As newsh stated the arms should be attached to the drip tray look back to where the roof slides to the drip tray will be jammed or the arms are jammed in the track a length of welding wire with a hook bent at one end usually works to drag it back but read the link that was posted.Derek

            Comment


            • #7
              Thanks Derek, I took the glass panel out and cleaned away the debris and it seems to be working fine, will see when I have the rust treated and the new seal fitted.

              Comment

              Working...
              X