Announcement

Collapse
No announcement yet.

91 Coupe

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Plenty of beeping in the dash. Dont have a diagnostic reader, but ill order one today.

    Charged my battery last night and the starter turned, but died after 2 seconds. While using voltmeter i see the voltage going Down without anything "on" in the car. Either something is soaking my battery or the battery is pretty much broken. I will get a new battery anyways while im at it.

    Can someone confirm if the fuel pump gets voltage only when engine is turning?

    Comment


    • #17
      Originally posted by Lopez90 View Post
      Can someone confirm if the fuel pump gets voltage only when engine is turning?
      Got a New battery today and i can confirm myself

      The car didnt start though

      Comment


      • #18
        Check the timing hasn’t slipped

        S2 Coupe 3B Project


        Ur quattro restoration

        S2 Avant

        Boost is the new rock and roll!
        sigpic

        Comment


        • #19
          Check the basics,fuel and spark and as mentioned above,timing.
          How long has the car been stood? the injectors may be stuck shut.
          It's a love/hate relationship with the S2,i love it,it hates me

          Comment


          • #20
            The fuel line was swapped. Fired up right away after swapping

            I’ll make a proper introduction of the car and myself now that it finally starts

            Comment


            • #21
              Nice easy fix then!
              It's a love/hate relationship with the S2,i love it,it hates me

              Comment


              • #22
                Have spent a few hours these past days under the steeringwheel and fusebox to fix some of the spiderweb. Cables crossing everywhere
                One of the loose ends (found near fusebox under bonnet) goes to a fuse under the steeringwheel and continues to the left side of the car and up in the dash it seems. Anyone know where his home is under the fusebox?
                Tried to search around s2central without luck

                iah3.jpg
                The seller of the car had two S2's so he put the wrong cluster in my car. Was going to swap it to the real one today but i`m missing the yellow plug on this one?

                IMG_2637.JPG
                -
                Updated first post with some info and Pictures of the car!
                Last edited by Lopez90; 19th March 2020, 19:29.

                Comment


                • #23
                  Yellow plug is for outside temperature display, just swap it over.

                  Comment


                  • #24
                    Okay

                    Guess it's better for me to assemble the engine and see what works and not before i look further in the wires.

                    Comment


                    • #25
                      Cleaned the seats today. Suprisingly in good condition!
                      Attached Files

                      Comment


                      • #26
                        Originally posted by Lopez90 View Post
                        The fuel line was swapped. Fired up right away after swapping

                        I’ll make a proper introduction of the car and myself now that it finally starts
                        My uncle got a new Coupe project we'll be working on right after we installed the brake kit, mount and balance tires plus a couple of led light bar wiring on current Wrangler project. The owner described the same issues, gonna check and replace the fuel line first.

                        Comment


                        • #27
                          Interesting project. I look forward to seeing it done.

                          Comment

                          Working...
                          X