Announcement

Collapse
No announcement yet.

S2 ABY Computer MPG?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • S2 ABY Computer MPG?

    Hey guys,

    Had the dash cluster out to change a few lamps and try to ascertain why my speedo was playing up/MPG not working.

    After checking the cluster over, contact cleaner on all the plugs/sockets and returning - the speedo appears to be working fine after a short spin but the MPG is still static at 23.5...

    Any ideas where to look next?

    Cheers!
    Cheers,
    Grant

    S2 Coupe ABY '94

  • #2
    Anything guys?
    Cheers,
    Grant

    S2 Coupe ABY '94

    Comment


    • #3
      Is that average mpg or instantaneous mpg there is a difference

      Comment


      • #4
        Instantaneous MPG.
        Cheers,
        Grant

        S2 Coupe ABY '94

        Comment


        • #5
          I had similar issues on mine and replaced the main board to fix it
          Mike

          http://www.s2-audi.co.uk

          Comment


          • #6
            Mine used to do this on and off, after I had the clocks out once or twice it started working as normal again so assumed it must of been a bad connection on one of the block connectors, suppose just check all connectors are good give them a clean with Kontact cleaner and fingers crossed, hate trying to fettle electrical faults they can be a mare to trace. Do all the other readings work OK

            Comment


            • #7
              I had the dash cluster out, but never opened it up. I did blast the connectors with contact cleaner and made sure they were all firmly home.

              Are there more connectors inside the dash cluster? Any guides out there for disassembly?
              Cheers,
              Grant

              S2 Coupe ABY '94

              Comment


              • #8
                The trip computer comes off the pcb as a separate cluster so maybe those connectors need looking at and there is a sensor for the mpg which feeds the trip computer I think, maybe this is at fault, do all the other trip computer functions work OK

                Comment


                • #9
                  https://www.s2forum.com/forum/techni...-trip-computer
                  Check this thread out might help

                  Comment


                  • #10
                    Originally posted by Rikki Kitto View Post
                    The trip computer comes off the pcb as a separate cluster so maybe those connectors need looking at and there is a sensor for the mpg which feeds the trip computer I think, maybe this is at fault, do all the other trip computer functions work OK
                    I don't get instantaneous or average MPG. I get the 2 hour "take a break" indication and I also get mileage until tank empty display. The time clock sometimes resets too, so I think all internal connectors could do with a little clean and firm push home.
                    ​​​​​​
                    Thanks for the linked thread, I'll take a look now.
                    Cheers,
                    Grant

                    S2 Coupe ABY '94

                    Comment


                    • #11
                      After getting a lend of a friend's cluster, I found that everything worked as normal - so the signal from the diff was sound and the fault lay somewhere in my cluster.

                      I have (I think) traced the fault to one of the capacitors on the speedometer circuit board. It is labled as:

                      Philips 036 KO B8
                      180u
                      K
                      10V

                      Could someone kindly advise as to where I can find the same; or applicable; capacitor to replace this one?

                      I've provisionally purchased this one:

                      https://m.ebay.co.uk/itm/PANASONIC-E...QAAOxy8HlSa77m

                      And for anyone looking for a guide to disassemble the instrument cluster for whatever reason (including getting in amongst the speedo), it can be found here. Probably worth a sticky if it isn't already:

                      http://www.odometergears.com/documen...eplacement.pdf

                      Cheers
                      Last edited by GrantGam; 10th June 2018, 01:25.
                      Cheers,
                      Grant

                      S2 Coupe ABY '94

                      Comment


                      • #12
                        That cap is correct, it’s an electrolytic so needs to go in the right way round, the neg side looks like it’s marked on the original.

                        S2 Coupe 3B Project


                        Ur quattro restoration

                        S2 Avant

                        Boost is the new rock and roll!
                        sigpic

                        Comment


                        • #13
                          Cheers.

                          The other capacitor measured in around 56uF which I'm happy enough with because my multimeter leads are on the way out.

                          Will be chuffed if the speedo comes back to life for a £2 capacitor
                          Cheers,
                          Grant

                          S2 Coupe ABY '94

                          Comment


                          • #14
                            An update guys, trip computer and speedo are now operational again 180uF capacitor change did the trick. Chuffed!

                            Not so chuffed at being able to see my MPG again though, forgot how gutsy the old girl is!
                            Cheers,
                            Grant

                            S2 Coupe ABY '94

                            Comment


                            • #15

                              Comment

                              Working...
                              X