Announcement

Collapse
No announcement yet.

Hellp s6 2.2 turbo no power on load

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hellp s6 2.2 turbo no power on load

    Hi everyone

    I have a problem with my 1995 audi s6 c4 2.2 turbo when I drive in normal mode like city everything is ok when i go on motorway and want to give gas to the floor the engine loses power , judders and can't get more then 4k rpm at all, as well loos speed instead gaining it . Even i trade at home and cannot get 4k rpm Just doesn't go over 3500 RPM I don have any engine upgrades

    Maby some one had similar problem

    Thanks in advance

  • #2
    Boost leak/ dirty maf?
    ABY Cricket Green Pearl Coupe, blk leather
    THE ONLY TROUBLE WITH DOING NOTHING IS KNOWING WHEN YOUR FINISHED!!!

    Comment


    • #3
      I had this and it was the fuel pump. As said above, could be boost leak, maf pins etc, etc, etc!
      Nothelle S2 Avant
      Wr Ur Quattro in restoration
      S2 Coupe getting a tidy up

      Comment


      • #4
        I check all pipes no leak. and its boosts until around 3500k rpm and than its like choking up.

        Comment


        • #5
          and when its choking up I can small fuel, its like it over fuel or not burning fuel

          Comment


          • #6
            Pull codes with Vagcom

            Do a proper boost leak test, plug the MAF hose and pressurise to 1 Bar.

            S2 Coupe 3B Project


            Ur quattro restoration

            S2 Avant

            Boost is the new rock and roll!
            sigpic

            Comment


            • #7
              Hello guys reading this post reminds of the time I had a similar problem with my S2 it turned out it was the catalytic converter had collapsed blocking the exhaust ok up to 3500 rpm then checked just a thougjt

              Comment


              • #8
                Could also be knock sensors, pull codes from the ECU and see what's what.

                Comment


                • #9
                  Check the engine timing and also the recirculating blow off valve

                  Comment


                  • #10
                    Originally posted by DEREKCO View Post
                    Hello guys reading this post reminds of the time I had a similar problem with my S2 it turned out it was the catalytic converter had collapsed blocking the exhaust ok up to 3500 rpm then checked just a thougjt
                    Had the same problem on my 96' S6, cats were completely collapsed, could not build any boost.
                    1996 Audi UrS6

                    Comment

                    Working...
                    X